Solucionar la instalación de ruby con rvm 1.21.17 en Mac OS X 10.8.4

Hola de nuevo a todos,

hoy os traigo otra solución a un problema que me acaba de surgir instalando una versión de ruby a través de rvm en mi entorno de programación RoR en Mac OS X 10.8.4 (el mismo que os comenté cómo instalar en otro post anterior).

El problema que os traigo se da a instalar una versión de ruby con rvm, en mi caso la instrucción que ha provocado este error es:

$>rvm install ree-1.8.7-2012.02

y tras intentar instalarse en mi ordenador, he obtenido el siguiente error:

Error running ‘env CFLAGS=-I/usr/local/opt/libyaml/include -I/usr/local/opt/readline/include -I/usr/local/opt/libksba/include -I/usr/local/opt/openssl098/include LDFLAGS=-L/usr/local/opt/libyaml/lib -L/usr/local/opt/readline/lib -L/usr/local/opt/libksba/lib -L/usr/local/opt/openssl098/lib ./installer -a /Users/[user]/.rvm/rubies/ree-1.8.7-2012.02 –no-tcmalloc –dont-install-useful-gems’,
please read /Users/[user]/.rvm/log/ree-1.8.7-2012.02/1377025151_install.log

Decidme si no es bonico🙂

La solución que yo he encontrado es la siguiente:

1. Antes de este error me salió un warning advirtiéndome de que no disponía de la última versión de openssl. Así que a través de homebrew instalé la última versión:

$> brew install openssl

2. Actualicé rvm a la última versión:

$> rvm get head

3. Volví a instalar dicha versión de ruby

$> rvm install ree

Esta vez todo fue como la seda🙂

Acerca de

Ingeniero Informático. RoR Developer

Publicado en Informática, Ruby on Rails

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: